
Manuale Utente

Il manuale utente ha lo scopo di mostrare come interagire con LionHell II e

fare da guida nell’installazione dei programmi necessari per la programma-

zione.

La Sezione descrive come controllare il robot, come accenderlo e come

funziona il telecomando.

La Sezione fornisce alcune informazioni di carattere generale sulla compo-

nentistica di LionHell II e del telecomando.

La Sezione fornisce gli indirizzi URL utili per il download del software

necessario, i manuali utente e le guide, alcuni tutorial e i datasheet dei

componenti.

La Sezione descrive cosa è necessario fare per iniziare a programmare e poter

successivamente installare i programmi necessari.

La Sezione descrive il programma Atmel Studio e i passi necessari per creare

un nuovo progetto per poter modificare il firmware di LionHell II.

La Sezione descrive come trasferire il firmware sulla scheda di controllo

CM-510.

La Sezione mostra come programmare l’XBee e come impostare i valori per

poter accedere all’XBee di LionHell II.

La Sezione , infine, è costituita da una serie di domande e risposte riguardanti

LionHell II e il telecomando.

1



2

Come interagire con LionHell II

LionHell II è un robot dotato di sei Wheg che gli permettono di scalare piccoli,

medi e grandi ostacoli (al massimo pari al doppio della sua altezza), può

funzionare per mezzo di una alimentazione a batteria o tramite cavo collegato

direttamente alla corrente elettrica. Il controllo di LionHell II avviene per

mezzo del telecomando mostrato in Figura 1b. Il pulsante nero al centro

del corpo di LionHell II è il pulsante di accensione, mentre il telecomando

è dotato di un interruttore di accensione (ON/OFF) e di un pulsante. Il

movimento di LionHell II è possibile solo se si muove il telecomando mentre

il pulsante rosso è premuto. Puntando la punta del cappello del telecomando

in avanti e con il bottone rosso rivolto verso l’alto è possibile muovere il

robot nella direzione desiderata: ruotando il telecomando lungo il proprio

asse a destra e a sinistra, LionHell II ruoterà a destra o a sinistra, mentre

alzando o abbassando il telecomando è possibile rispettivamente far avanzare

o indietreggiare il robot.
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Figura 1: LionHell II e Telecomando

(a) LionHell II

(b) Telecomando
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Informazioni di carattere generale

LionHell II è un robot esapode con le seguenti caratteristiche:

• 10 servomotori attuatori Dynamixel AX-12 appartenenti al kit chiama-

to Bioloid, commercializzato dalla società Robotis;

• 1 scheda di controllo CM-510, dotata di controller ATMega2561;

• 4 sensori telemetri IR Sharp GP2D120X;

• 1 accelerometro a tre assi MMA7361;

• 1 XBee 4214A;

• 1 XBee Explorer Regulated;

• 1 batteria Nano Tech da 4000 mAh;

• 1 trasformatore AC-DC con tensione di uscita 12 V e corrente massima

5 A;

• 1 pulsante nero stabile normalmente aperto ON/OFF.

Il telecomando è dotato di:

• 1 batteria da 9 V e 250 mAh;

• 1 XBee Explorer Regulated;

• 1 XBee 4214A;

• 1 accelerometro analogico a tre assi ADXL335;

• 1 interruttore switch ON/OFF;

• 1 pulsante rosso instabile normalmente aperto.
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Indirizzi URL utili

Di seguito sono elencati gli indirizzi utili riguardanti prevalentemente tuto-

rial, download di programmi e datasheet dei componenti (ultimo accesso:

2015-03-23):

• http://www.robotgarage.org/wiki/index.php?title=LionHell_Mc

Millan#Download: il sito di LionHell II, con alcuni dati tecnici e da

cui è possibile scaricare il firmware del robot;

• http://support.robotis.com/en/: il manuale di supporto della Ro-

botis, particolarmente utile all’inizio;

• http://winavr.sourceforge.net/: il link di download di WinAVR,

fondamentale per programmare in AVR;

• http://www.atmel.com/microsite/atmel_studio6/: il link di down-

load di Atmel Studio, necessario per modificare il firmware;

• http://x-ctu.software.informer.com/download/: il link di down-

load di X-CTU, necessario per programmare l’XBee;

• http://roboplus.software.informer.com/download/: il link di do-

wnload di RoboPlus, necessario per trasferire il firmware modificato su

LionHell II;

• http://www.libelium.com/development/waspmote/documentation/

x-ctu-tutorial/: Tutorial di X-CTU;

• http://matteo.luccalug.it/wp-content/uploads/2011/11/easy_b

ee.pdf: Tutorial in italiano dell’XBee;

• http://www.jsjf.demon.co.uk/xbee/xbee.pdf: Guida ufficiale in in-

glese dell’XBee;

• http://support.robotis.com/en/software/roboplus/roboplus_te

rminal_main.htm: Guida al terminale RoboPlus;

http://www.robotgarage.org/wiki/index.php?title=LionHell_McMillan#Download
http://www.robotgarage.org/wiki/index.php?title=LionHell_McMillan#Download
http://support.robotis.com/en/
http://winavr.sourceforge.net/
http://www.atmel.com/microsite/atmel_studio6/
http://x-ctu.software.informer.com/download/
http://roboplus.software.informer.com/download/
http://www.libelium.com/development/waspmote/documentation/x-ctu-tutorial/
http://www.libelium.com/development/waspmote/documentation/x-ctu-tutorial/
http://matteo.luccalug.it/wp-content/uploads/2011/11/easy_bee.pdf
http://matteo.luccalug.it/wp-content/uploads/2011/11/easy_bee.pdf
http://www.jsjf.demon.co.uk/xbee/xbee.pdf
http://support.robotis.com/en/software/roboplus/roboplus_terminal_main.htm
http://support.robotis.com/en/software/roboplus/roboplus_terminal_main.htm
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• http://www.produktinfo.conrad.com/datenblaetter/250000-274999/

261767-an-01-ml-Power_Peak_A4_EQ_LCD_230V_12V_de_en_fr_es.p

df: Manuale utente del carica batterie Power Peak A4 EQ-LCD;

• http://www.sharpsma.com/webfm_send/1205: datasheet del teleme-

tro IR Sharp GP2D120X;

• http://www.dfrobot.com/wiki/index.php/SHARP_GP2D120X_IR_rang

er_sensor_(4-30cm)_(SKU:SEN0143): link della dfrobot che descrive

il codice del telemetro IR GP2D120X;

• http://support.robotis.com/en/product/auxdevice/controller/

cm510_manual.htm: datasheet e manuale della scheda di controllo CM-

510;

• http://support.robotis.com/en/product/dynamixel/ax_series/d

xl_ax_actuator.htm: datasheet e manuale dell’attuatore AX-12;

• http://www.apexelectrix.com/PDFs/MMA7361/MMA7361_module_dat

asheet.pdf: datasheet del modulo dell’accelerometro a tre assi MMA7361;

• http://www.apexelectrix.com/PDFs/MMA7361L.pdf: datasheet del

chip dell’accelerometro a tre assi MMA7361;

• http://www.hobbyking.com/hobbyking/store/__21939__Turnigy_n

ano_tech_4000mah_3S_40_80C_Lipo_Pack_TRA2849_Slash_Rustler_

Bandit_Stampede_compatible_.htm: dati riguardanti la batteria Na-

no Tech utilizzata;

• https://www.sparkfun.com/datasheets/Wireless/Zigbee/XBee-Dat

asheet.pdf: datasheet dell’XBee 4214A;

• http://www.homotix.it/catalogo/moduli-xbee-e-accessori-689/

xbee-explorer-regulated: dati riguardanti l’XBee Explorer Regula-

ted;

• http://www.homotix.it/catalogo/accelerometri/triple-axis-acc

elerometer-breakout-adxl335: dati riguardanti l’accelerometro del

telecomando ADXL335;

http://www.produktinfo.conrad.com/datenblaetter/250000-274999/261767-an-01-ml-Power_Peak_A4_EQ_LCD_230V_12V_de_en_fr_es.pdf
http://www.produktinfo.conrad.com/datenblaetter/250000-274999/261767-an-01-ml-Power_Peak_A4_EQ_LCD_230V_12V_de_en_fr_es.pdf
http://www.produktinfo.conrad.com/datenblaetter/250000-274999/261767-an-01-ml-Power_Peak_A4_EQ_LCD_230V_12V_de_en_fr_es.pdf
http://www.sharpsma.com/webfm_send/1205
http://www.dfrobot.com/wiki/index.php/SHARP_GP2D120X_IR_ranger_sensor_(4-30cm)_(SKU:SEN0143)
http://www.dfrobot.com/wiki/index.php/SHARP_GP2D120X_IR_ranger_sensor_(4-30cm)_(SKU:SEN0143)
http://support.robotis.com/en/product/auxdevice/controller/cm510_manual.htm
http://support.robotis.com/en/product/auxdevice/controller/cm510_manual.htm
http://support.robotis.com/en/product/dynamixel/ax_series/dxl_ax_actuator.htm
http://support.robotis.com/en/product/dynamixel/ax_series/dxl_ax_actuator.htm
http://www.apexelectrix.com/PDFs/MMA7361/MMA7361_module_datasheet.pdf
http://www.apexelectrix.com/PDFs/MMA7361/MMA7361_module_datasheet.pdf
http://www.apexelectrix.com/PDFs/MMA7361L.pdf
http://www.hobbyking.com/hobbyking/store/__21939__Turnigy_nano_tech_4000mah_3S_40_80C_Lipo_Pack_TRA2849_Slash_Rustler_Bandit_Stampede_compatible_.htm
http://www.hobbyking.com/hobbyking/store/__21939__Turnigy_nano_tech_4000mah_3S_40_80C_Lipo_Pack_TRA2849_Slash_Rustler_Bandit_Stampede_compatible_.htm
http://www.hobbyking.com/hobbyking/store/__21939__Turnigy_nano_tech_4000mah_3S_40_80C_Lipo_Pack_TRA2849_Slash_Rustler_Bandit_Stampede_compatible_.htm
https://www.sparkfun.com/datasheets/Wireless/Zigbee/XBee-Datasheet.pdf
https://www.sparkfun.com/datasheets/Wireless/Zigbee/XBee-Datasheet.pdf
http://www.homotix.it/catalogo/moduli-xbee-e-accessori-689/xbee-explorer-regulated
http://www.homotix.it/catalogo/moduli-xbee-e-accessori-689/xbee-explorer-regulated
http://www.homotix.it/catalogo/accelerometri/triple-axis-accelerometer-breakout-adxl335
http://www.homotix.it/catalogo/accelerometri/triple-axis-accelerometer-breakout-adxl335
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• http://www.droids.it/data_sheets/990.006%20datasheet.pdf: da-

tasheet dell’XBee DTE serial board, utilizzata per connettere l’XBee

al computer;

• http://support.robotis.com/en/product/auxdevice/interface/l

n101_manual.htm: datasheet del cavo di programmazione LN-101.

Per iniziare

Questa guida si propone di essere un aiuto nei passi necessari riguardanti

l’installazione dei programmi per la modifica del firmware di LionHell II e la

modifica dei valori dell’XBee. I programmi sono stati testati ed installati su

un sistema operativo Windows 7.

Il firmware di LionHell II è salvato all’interno del file “AVRGCC1.c” ed è

scritto in codice C-embedded, ma per poterlo modificare e potersi connettere

al robot per trasferire il firmware così modificato è necessario seguire alcuni

passi fondamentali, descritti alla pagina Robotis e-Manual (Home > Soft-

ware Help > Software development kit > Embedded C > CM510/CM700 >

Getting Started), che corrisponde alla pagina di supporto Robotis e-Manual

(si noti che il manuale è scritto in lingua Coreana, Inglese, Giapponese e

Cinese):

1. scaricare ed installare WinAVR, necessario per la programmazione AVR,

seguendo la procedura indicata nel manuale Robotis e-Manual (Ho-

me > Software Help > Software development kit > Embedded C >

CM510/CM700 > Getting Started > Installing WinAVR);

2. scaricare ed installare il software Atmel Studio necessario per modi-

ficare il firmware come mostrato nel manuale Robotis e-Manual (Ho-

me > Software Help > Software development kit > Embedded C >

CM510/CM700 > Getting Started > Installing Atmel Studio);

3. preparare l’ambiente di lavoro del software Atmel Studio come mostrato

nel manuale Robotis e-Manual (Home > Software Help > Software

http://www.droids.it/data_sheets/990.006%20datasheet.pdf
http://support.robotis.com/en/product/auxdevice/interface/ln101_manual.htm
http://support.robotis.com/en/product/auxdevice/interface/ln101_manual.htm
http://support.robotis.com/en/
http://winavr.sourceforge.net/
http://support.robotis.com/en/
http://www.atmel.com/microsite/atmel_studio6/
http://support.robotis.com/en/
http://support.robotis.com/en/
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development kit > Embedded C > CM510/CM700 > Getting Started

> Setting Environment) ignorandone l’esempio;

4. accedere alla pagina di LionHell Mc Millan da cui è possibile scaricare

il firmware, o utilizzare il disco su cui è presente il codice necessa-

rio (si noti che solo il file AVRGCC1.c è fondamentale ai fini della

programmazione del codice di LionHell II);

5. accedere al manuale Robotis e-Manual (Home > Software Help > Soft-

ware development kit > Embedded C > CM510/CM700) e scaricare il

file “embeded_c(cm510_v1.02).zip” e successivamente decomprimerlo.

NOTE: Si noti che il carattere “W barrato” indica il carattere “\” in Coreano.

Creare un progetto in Atmel Studio

Per creare un nuovo progetto “LionHell” è necessario aprire Atmel Studio pre-

cedentemente installato (può metterci parecchio tempo) e seguire la seguente

procedura:

1. creare un nuovo progetto “File > New > Project”;

2. nella nuova schermata aperta, nella sezione “Name” digitare il nome

del progetto “LionHell”;

3. selezionare “GCC C Executable Project” in corrispondenza di “Recent-

Templates > Installed Templates > C/C++” e premere OK

4. selezionare “ATmega2561” come indicato alla pagina riguardante Lio-

nHell Mc Millan (App./Boot Memory (Kbytes) = 256, Data Memory

(bytes) = 8192, EEPROM (bytes) = 4096) e premere OK;

5. il progetto è stato creato, ma il file “AVRGCC1.c” non è ancora sta-

to aggiunto: premere con il pulsante destro sulla scritta in grassetto

“LionHell” (o il nome del progetto) presente all’interno del riquadro

“Solution Explorer” e selezionare “Add > Existing item” e selezionare

il file “AVRGCC1.c”, quindi premere OK;

http://www.robotgarage.org/wiki/index.php?title=LionHell_McMillan#Download
http://support.robotis.com/en/
http://www.robotgarage.org/wiki/index.php?title=LionHell_McMillan
http://www.robotgarage.org/wiki/index.php?title=LionHell_McMillan
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6. a questo punto è necessario modificare alcuni valori nelle proprietà del

progetto stesso, raggiungibili tramite il percorso “Project > LionHell

Properties...”;

7. nella nuova sezione aperta (avrà il nome del progetto, in questo ca-

so “LionHell”) selezionare “Toolchain > AVR/GNU C Compiler >

Directories” e in corrispondenza di “Include Paths”, premere sull’i-

cona , quindi selezionare e scrivere l’indirizzo della cartella

“include” presente all’interno del file “embeded_c(cm510_v1.02).zip”

decompresso, con la spunta su “Relative Path” (come nell’esempio

“.../embeded_c(cm510_v1.02)/include”), e premere su OK;

8. selezionare “Toolchain > AVR/GNU Linker > Libraries” e nel riquadro

basso “Library search path (-WI,L)”, premere sull’icona , quindi

selezionare e scrivere l’indirizzo della cartella “lib” presente al-

l’interno del file “embeded_c(cm510_v1.02).zip” decompresso prece-

dentemente, senza la spunta su “Relative Path” (come nell’esempio

“C:\embeded_c(cm510_v1.02)\lib”), e premere su OK;

9. selezionare “Toolchain > AVR/GNU Linker > Libraries” e nel riqua-

dro alto “Libraries (-WI,-I)” premere sull’icona e digitare “libdy-

namixel.a” e premere OK, ripetendo l’operazione anche per le librerie

“libserial.a” e “libzigbee.a”;

10. salvare le modifiche apportate alle proprietà del progetto;

Per mezzo di Atmel Studio sarà quindi possibile modificare e successivamente

aggiornare LionHell II.

Per ottenere una più chiara lettura del codice, consigliamo di attivare i numeri

di fianco alla linea di codice (per fare questo è necessario selezionare Tools

> Options > Text Editor > GCC > Display e selezionare “Line numbers”).
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Figura 2: Cavi di programmazione con CM-510 e relativa porta

(a) Cavo di programmazione A (b) Cavo di programmazione B

(c) Porta di programmazione

Trasferire il firmware modificato

Per trasferire il firmware modificato è necessario utilizzare il cavo (LN-101)

mostrato in Figura 2a o quello di Figura 2b e connetterlo alla porta della sche-

da di controllo CM-510 mostrata in Figura 2c, evidenziata da un rettangolo

rosso.

Per poter interagire con LionHell II, è necessario scaricare ed installare Ro-

boPlus, ed avviarne il terminale. Una volta avviato il terminale, seguire la

seguente procedura:

1. per entrare nel boot loader, tenere premuto il bottone “#” (Shift + 3)

mentre si accende il controller o si preme il pulsante si reset posizionato

http://support.robotis.com/en/product/auxdevice/interface/ln101_manual.htm
http://roboplus.software.informer.com/download/
http://roboplus.software.informer.com/download/
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Figura 3: Terminale RoboPlus, si è entrati nel boot loader

sulla scheda di controllo. Se l’operazione è stata eseguita correttamente,

apparirà la scritta mostrata in Figura 3;

2. premere su “setup > connect”;

3. nella nuova finestra che si aprirà, impostare:

• Port: COM1

• Baudrate: 57600 bps

4. ora il PC è connesso con la scheda di controllo CM-510;

5. per trasmettere un file, in questo caso il firmware modificato, premere

su “Files > Trasmit file” e caricare il file;

6. per terminare il lavoro, avviare il robot con il cavo di programmazione

ancora connesso, digitando “GO” (il programma è eseguito dall’indiriz-

zo 0) o “G [indirizzo]” (il programma è eseguito a partire dall’indirizzo

selezionato, scritto in esadecimale) nel terminale (nel caso sia previsto

che il robot si muova non appena premiate il pulsante di accensione,

state attenti al cavo) oppure resettando la scheda di controllo.

Ulteriori informazioni sono presenti nel manuale Robotis e-Manual (Home >

Software Help > Software development kit > Embedded C > CM510/CM700

> Programming > Boot Loader) e alla pagina del terminale RoboPlus.

http://support.robotis.com/en/
http://support.robotis.com/en/software/roboplus/roboplus_terminal_main.htm
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Figura 4: Cavo di connessione XBee - PC

Come programmare l’XBee

Per programmare l’XBee è necessario scaricare ed installare un program-

ma chiamato X-CTU. Per procedere all’installazione e avere un tutorial sul

funzionamento del programma, riferirsi al Tutorial - X-CTU.

Una volta installato X-CTU, è necessario collegare l’XBee che si vuole mo-

dificare al cavo di connessione mostrato in Figura 4 (costituito da un XBee

DTE serial board), collegare il cavo al computer e procedere all’avvio del

programma.

Una volta avviato X-CTU, per modificare e rilevare l’XBee, è necessario:

1. premere sull’icona per cercare la presenza di XBee connessi;

2. selezionare la porta USB corrispondente all’XBee connesso al computer

e premere su next;

3. affinché la ricerca vada a buon fine e sia possibile configurare l’XBee,

è necessario inserire i seguenti dati:

• Baud rate: 115200

• Data bit: 8

http://x-ctu.software.informer.com/download/
http://www.libelium.com/development/waspmote/documentation/x-ctu-tutorial/
http://www.droids.it/data_sheets/990.006%20datasheet.pdf
http://www.droids.it/data_sheets/990.006%20datasheet.pdf
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• Parity: none

• Stop bits: 1

• Flow control: none

4. a questo punto si è connessi all’XBee ed è possibile effettuare le modi-

fiche del caso.

Per ottenere maggiori informazioni riguardanti l’XBee riferirsi al Datasheet

-XBee 4214A, al manuale utente Tutorial - XBee in italiano e alla Guida -

XBee in inglese, fondamentali per comprenderne il funzionamento.

Domande e Risposte

• Come faccio a ricaricare la batteria Nano Tech di LionHell II?

– La batteria è ricaricabile per mezzo del carica batterie Power Peak

A4 EQ-LCD mostrato in Figura 5a (la tensione in ingresso deve

essere compresa tra i 12 e i 15 V ,consigliabile 14 V ). La batteria

da ricaricare va connessa al cavo sensore di voltaggio, che misura

la tensione, la carica massima e la corrente in ingresso: una volta

connesso alla scheda di controllo e ai cavi di carica come mostrato

in Figura 5b, è possibile avviare la ricarica tenendo premuto per

circa 10 secondi il pulsante start (è possibile riconoscere la carica

Figura 5: Carica batteria per LionHell II

(a) Disconnesso (b) In carica

https://www.sparkfun.com/datasheets/Wireless/Zigbee/XBee-Datasheet.pdf
https://www.sparkfun.com/datasheets/Wireless/Zigbee/XBee-Datasheet.pdf
http://matteo.luccalug.it/wp-content/uploads/2011/11/easy_bee.pdf
http://www.jsjf.demon.co.uk/xbee/xbee.pdf
http://www.jsjf.demon.co.uk/xbee/xbee.pdf
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in corso dal led dello stato verde che lampeggia due o tre volte ogni

dieci o quindici secondi). Quando la batteria è carica al 95%, il led

di stato diventerà arancione, mentre quando la batteria è carica

totalmente il carica batteria suona per 15 secondi. Per maggiori

informazioni riguardanti il carica batteria ci si riferisca al Manuale

utente - Power Peak A4 EQ-LCD;

• Come faccio a sostituire le pile e modificare l’XBee installato nel tele-

comando?

– Il telecomando è smontabile come mostrato in Figura 6 e la bat-

teria di cui ha bisogno è una batteria da 9 V e 250 mAh;

• Il robot si blocca improvvisamente senza motivo, mentre altre volte

funziona senza problemi, come mai?

– Alcuni cavi sono stati fatti a mano e talvolta la connessione po-

trebbe saltare, controlla le entrate dei cavi nella scheda CM-510

se sono rovinati o se semplicemente non sono bloccati bene;

• I motori fanno rumori strani, come se scattassero, cosa devo fare?

– L’ingranaggio interno dell’attuatore AX-12 del robot si è danneg-

giato, è necessario rimuovere l’attuatore e ripararlo, o sostituirlo

con uno funzionante. Per smontare ed aprire l’attuatore dan-

neggiato, si faccia riferimento alla guida riguardante l’attuatore

AX-12, in fondo alla pagina;

• Alcuni attuatori improvvisamente non si muovono, cosa sta succeden-

do?

– Controlla che tutti i cavi degli attuatori siano connessi tra loro e

incastrati bene, e nel caso controlla se i cavi degli attuatori si siano

danneggiati o meno, dato che raramente si tratta dell’attuatore

stesso rotto;

http://www.produktinfo.conrad.com/datenblaetter/250000-274999/261767-an-01-ml-Power_Peak_A4_EQ_LCD_230V_12V_de_en_fr_es.pdf
http://www.produktinfo.conrad.com/datenblaetter/250000-274999/261767-an-01-ml-Power_Peak_A4_EQ_LCD_230V_12V_de_en_fr_es.pdf
http://support.robotis.com/en/product/dynamixel/ax_series/dxl_ax_actuator.htm
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Figura 6: Telecomando smontato

• I giunti motorizzati centrali del robot muovono la parte frontale del

robot in su e in giù ripetutamente, e dopo pochi secondi si blocca

tutto, come mai?

– Vi è un ostacolo che blocca la visuale dei telemetri IR Sharp

GP2D120X. Si noti che i sensori individuano la presenza di ostacoli

in un raggio di 10°-15° intorno al sensore.
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Datasheet

Telemetro

Modello: GP2D120X

Produttore: Sharp Corporation

http://www.sharpsma.com/webfm_send/1205

http://www.dfrobot.com/wiki/index.php/SHARP_GP2D120X_IR_ranger_s

ensor_(4-30cm)_(SKU:SEN0143)

Scheda di Controllo

Modello: CM-510

Produttore: Robotis

http://support.robotis.com/en/product/auxdevice/controller/cm510_

manual.htm

Microcontrollore della Scheda di Controllo

Modello: ATMega2561

Produttore: Atmel

http://www.atmel.com/Images/2549S.pdf

17

http://www.sharpsma.com/webfm_send/1205
http://www.dfrobot.com/wiki/index.php/SHARP_GP2D120X_IR_ranger_sensor_(4-30cm)_(SKU:SEN0143)
http://www.dfrobot.com/wiki/index.php/SHARP_GP2D120X_IR_ranger_sensor_(4-30cm)_(SKU:SEN0143)
http://support.robotis.com/en/product/auxdevice/controller/cm510_manual.htm
http://support.robotis.com/en/product/auxdevice/controller/cm510_manual.htm
http://www.atmel.com/Images/2549S.pdf
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Servomotore

Modello: Dynamixel AX-12

Produttore: Robotis

http://support.robotis.com/en/product/dynamixel/ax_series/dxl_ax_

actuator.htm

Accelerometro di LionHell II

Modello: accelerometro a tre assi MMA7361

Produttore: Apex Electrix

http://www.apexelectrix.com/PDFs/MMA7361/MMA7361_module_datasheet

.pdf

http://www.apexelectrix.com/PDFs/MMA7361L.pdf

Batteria di LionHell II

Modello: TRA2849

Produttore: Turnigy

http://www.hobbyking.com/hobbyking/store/__21939__Turnigy_nano_te

ch_4000mah_3S_40_80C_Lipo_Pack_TRA2849_Slash_Rustler_Bandit_Stamp

ede_compatible_.htm

XBee

Modello: 4214A-XBee

Produttore: Sparkfun Electronics

https://www.sparkfun.com/datasheets/Wireless/Zigbee/XBee-Datasheet.pdf

http://support.robotis.com/en/product/dynamixel/ax_series/dxl_ax_actuator.htm
http://support.robotis.com/en/product/dynamixel/ax_series/dxl_ax_actuator.htm
http://www.apexelectrix.com/PDFs/MMA7361/MMA7361_module_datasheet.pdf
http://www.apexelectrix.com/PDFs/MMA7361/MMA7361_module_datasheet.pdf
http://www.apexelectrix.com/PDFs/MMA7361L.pdf
http://www.hobbyking.com/hobbyking/store/__21939__Turnigy_nano_tech_4000mah_3S_40_80C_Lipo_Pack_TRA2849_Slash_Rustler_Bandit_Stampede_compatible_.htm
http://www.hobbyking.com/hobbyking/store/__21939__Turnigy_nano_tech_4000mah_3S_40_80C_Lipo_Pack_TRA2849_Slash_Rustler_Bandit_Stampede_compatible_.htm
http://www.hobbyking.com/hobbyking/store/__21939__Turnigy_nano_tech_4000mah_3S_40_80C_Lipo_Pack_TRA2849_Slash_Rustler_Bandit_Stampede_compatible_.htm
https://www.sparkfun.com/datasheets/Wireless/Zigbee/XBee-Datasheet.pdf
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XBee Explorer Regulated

Modello: XBee-regulated-v14

Produttore: Sparkfun Electronics

http://www.homotix.it/catalogo/moduli-xbee-e-accessori-689/xbee

-explorer-regulated

Accelerometro del Telecomando

Modello: ADXL335

Produttore: Sparkfun Electronics

http://www.homotix.it/catalogo/accelerometri/triple-axis-acceler

ometer-breakout-adxl335

XBee DTE serial board

Modello: XBee DTE serial board 990.006

Produttore: Droids

http://www.droids.it/data_sheets/990.006%20datasheet.pdf

Cavo di Programmazione

Modello: LN-101

Produttore: Robotis

http://support.robotis.com/en/product/auxdevice/interface/ln101_

manual.htm

http://www.homotix.it/catalogo/moduli-xbee-e-accessori-689/xbee-explorer-regulated
http://www.homotix.it/catalogo/moduli-xbee-e-accessori-689/xbee-explorer-regulated
http://www.homotix.it/catalogo/accelerometri/triple-axis-accelerometer-breakout-adxl335
http://www.homotix.it/catalogo/accelerometri/triple-axis-accelerometer-breakout-adxl335
http://www.droids.it/data_sheets/990.006%20datasheet.pdf
http://support.robotis.com/en/product/auxdevice/interface/ln101_manual.htm
http://support.robotis.com/en/product/auxdevice/interface/ln101_manual.htm

